summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-04-08 23:36:05 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-04-10 20:54:17 +0200
commit40cc1884efa2aab5441c396166d97a33568849ae (patch)
treed96abbd0d3883a270e66fdce559b3bafa6ae277b
parent8219da2c7fbb7e121ffec9cbd8ea12cc92ea70a0 (diff)
downloadguix-patches-40cc1884efa2aab5441c396166d97a33568849ae.tar
guix-patches-40cc1884efa2aab5441c396166d97a33568849ae.tar.gz
gnu: emacs-helm-gtags: Don't use unstable tarball.
* gnu/packages/emacs-xyz.scm (emacs-helm-gtags)[source]: Use GIT-FETCH and GIT-FILE-NAME.
-rw-r--r--gnu/packages/emacs-xyz.scm18
1 files changed, 9 insertions, 9 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 2264c3a564..959a8c13ce 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -9413,15 +9413,15 @@ and @code{erc-send-modify-hook} to download and show images.")
(package
(name "emacs-helm-gtags")
(version "1.5.6")
- (source (origin
- (method url-fetch)
- (uri (string-append
- "https://github.com/syohex/emacs-helm-gtags/archive/"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
- (sha256
- (base32
- "1a10snhg6nnnan6w9a7mcziy26vxbsr3c35i0gcarnkdp2yqng36"))))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/syohex/emacs-helm-gtags.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0zyspn9rqfs3hkq8qx0q1w5qiv30ignbmycyv0vn3a6q7a5fsnhx"))))
(build-system emacs-build-system)
(propagated-inputs
`(("emacs-helm" ,emacs-helm)))