summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2019-10-31 09:42:48 -0400
committerTimothy Sample <samplet@ngyro.com>2019-11-20 20:48:00 -0500
commit3ed40e10c8a13edb1d89e5f08a4c5d63213f647d (patch)
tree95a889c50c5201b41bd82d8444be758bf561a881
parent081d85d6f426524b7df2659ea419e4bdf033e9a6 (diff)
downloadguix-patches-3ed40e10c8a13edb1d89e5f08a4c5d63213f647d.tar
guix-patches-3ed40e10c8a13edb1d89e5f08a4c5d63213f647d.tar.gz
gnu: ghc-generics-sop: Update to 0.4.0.1.
* gnu/packages/haskell-xyz.scm (ghc-generics-sop): Update to 0.4.0.1. [inputs]: Add 'ghc-sop-core'.
-rw-r--r--gnu/packages/haskell-xyz.scm8
1 files changed, 5 insertions, 3 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 57c1ce71ab..5e1c3e3840 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -3767,7 +3767,7 @@ deriving mechanism in Haskell to arbitrary classes.")
(define-public ghc-generics-sop
(package
(name "ghc-generics-sop")
- (version "0.3.2.0")
+ (version "0.4.0.1")
(source
(origin
(method url-fetch)
@@ -3776,9 +3776,11 @@ deriving mechanism in Haskell to arbitrary classes.")
"generics-sop-" version ".tar.gz"))
(sha256
(base32
- "168v62i845jh9jbfaz3ldz8svz4wmzq9mf2vhb7pxlnbkk8fqq1h"))))
+ "160knr2phnzh2gldfv954lz029jzc7y8kz5xpmbf4z3vb5ngm6fw"))))
(build-system haskell-build-system)
- (inputs `(("ghc-transformers-compat" ,ghc-transformers-compat)))
+ (inputs
+ `(("ghc-sop-core" ,ghc-sop-core)
+ ("ghc-transformers-compat" ,ghc-transformers-compat)))
(home-page "https://github.com/well-typed/generics-sop")
(synopsis "Generic Programming using True Sums of Products for Haskell")
(description "This Haskell package supports the definition of generic