summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Lo <peterloleungyau@gmail.com>2020-09-11 07:21:31 +0200
committerRicardo Wurmus <rekado@elephly.net>2020-09-11 07:21:31 +0200
commit3ad68ec251a008d6f5875f9235e75f5ce6399f15 (patch)
treebfa188dcafe81c51581326f77d562796acaac95f
parent6995f99ce75cb0199dc96f80c9bf3d5e6f3ac402 (diff)
downloadguix-patches-3ad68ec251a008d6f5875f9235e75f5ce6399f15.tar
guix-patches-3ad68ec251a008d6f5875f9235e75f5ce6399f15.tar.gz
gnu: Add r-muhaz.
* gnu/packages/cran.scm (r-muhaz): New variable. Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
-rw-r--r--gnu/packages/cran.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index ad2e9ab2ec..ef6e502171 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -23287,3 +23287,28 @@ designed as a drop-in replacement for the RANN function @code{nn2}. In
addition, objects which include the k-d tree search structure can be returned
to speed up repeated queries of the same set of target points.")
(license license:bsd-3)))
+
+(define-public r-muhaz
+ (package
+ (name "r-muhaz")
+ (version "1.2.6.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "muhaz" version))
+ (sha256
+ (base32
+ "08qh43zx6h3yby44q2vxphfvmfdmqxpgyp0734yn341sy9n8pkkk"))))
+ (properties `((upstream-name . "muhaz")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-survival" ,r-survival)))
+ (native-inputs
+ `(("gfortran" ,gfortran)))
+ (home-page "https://cran.r-project.org/web/packages/muhaz/")
+ (synopsis "Hazard function estimation in survival analysis")
+ (description
+ "This package produces a smooth estimate of the hazard function for
+censored data.")
+ ;; Any version of the GPL.
+ (license license:gpl3+)))