summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-04-08 23:36:54 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-04-10 20:54:18 +0200
commit32ce5382ef043e560ff9e531b9e129271c0c255f (patch)
tree9247d97a84899f8156262ce62a106018b134472c
parent6c4f58ad605a622d886fb8c18c51630cd27dadcf (diff)
downloadguix-patches-32ce5382ef043e560ff9e531b9e129271c0c255f.tar
guix-patches-32ce5382ef043e560ff9e531b9e129271c0c255f.tar.gz
gnu: emacs-npm-mode: Don't use unstable tarball.
* gnu/packages/emacs-xyz.scm (emacs-npm-mode)[source]: Use GIT-FETCH and GIT-FILE-NAME.
-rw-r--r--gnu/packages/emacs-xyz.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 2ba7ac494c..e0d4ff59bd 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -9672,13 +9672,13 @@ timestamps and date-time format strings library for Emacs.")
(version "0.6.0")
(source
(origin
- (method url-fetch)
- (uri (string-append "https://github.com/mojochao/npm-mode/archive/"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mojochao/npm-mode.git")
+ (commit version)))
+ (file-name (git-file-name name version))
(sha256
- (base32
- "1kq1ww22dwf8c2i2b4z2ldbbmnihj65kb7n5vzvwkch9h4hxpqh5"))))
+ (base32 "1mh6nbffciw4yhv049kdhh796ysj1x21ndm3fwymhskb3dy0w1ss"))))
(build-system emacs-build-system)
(home-page "https://github.com/mojochao/npm-mode")
(synopsis "Minor mode for working with @code{npm} projects")