summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxime Devos <maximedevos@telenet.be>2021-08-25 16:04:59 +0200
committerMathieu Othacehe <othacehe@gnu.org>2021-09-20 11:15:09 +0000
commit26a336c20bd9f274c2117745828b514ceda18112 (patch)
tree0367539f710aa1093da16695375faf691298fc8b
parentbce0a7d3d87222286176f1bdb49b3028cbc5e46b (diff)
downloadguix-patches-26a336c20bd9f274c2117745828b514ceda18112.tar
guix-patches-26a336c20bd9f274c2117745828b514ceda18112.tar.gz
gnu: gdk-pixbuf: Find docbook when cross-compiling.
* gnu/packages/gtk.scm (gdk-pixbuf)[arguments]<#:phases>{patch-docbook}: Look for docbook in 'native-inputs' instead of 'inputs' when cross-compiling.
-rw-r--r--gnu/packages/gtk.scm14
1 files changed, 11 insertions, 3 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 6da70d47dc..017fd608b4 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -628,15 +628,23 @@ highlighting and other features typical of a source code editor.")
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'patch-docbook
- (lambda* (#:key inputs #:allow-other-keys)
+ ;; TODO(core-updates): Unconditionally look in (or native-inputs inputs)
+ (lambda* (#:key ,@(if (%current-target-system)
+ '(native-inputs)
+ '())
+ inputs #:allow-other-keys)
(with-directory-excursion "docs"
(substitute* "meson.build"
(("http://docbook.sourceforge.net/release/xsl/current/")
- (string-append (assoc-ref inputs "docbook-xsl")
+ (string-append (assoc-ref ,(if (%current-target-system)
+ '(or native-inputs inputs)
+ 'inputs) "docbook-xsl")
"/xml/xsl/docbook-xsl-1.79.2/")))
(substitute* (find-files "." "\\.xml$")
(("http://www.oasis-open.org/docbook/xml/4\\.3/")
- (string-append (assoc-ref inputs "docbook-xml")
+ (string-append (assoc-ref ,(if (%current-target-system)
+ '(or native-inputs inputs)
+ 'inputs) "docbook-xml")
"/xml/dtd/docbook/"))))
#t))
(add-before 'configure 'disable-failing-tests