summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorkiasoc5 <kiasoc5@disroot.org>2022-05-16 22:51:53 -0400
committerLudovic Courtès <ludo@gnu.org>2022-05-24 17:19:03 +0200
commit1ffee0cf985399406ca79c3d14fe4b1c2fd85455 (patch)
treebd09862970add9b048f6a5f44d7a6b146aa48708
parent29c931780897b78c8d1499b648692a84a7b5063d (diff)
downloadguix-patches-1ffee0cf985399406ca79c3d14fe4b1c2fd85455.tar
guix-patches-1ffee0cf985399406ca79c3d14fe4b1c2fd85455.tar.gz
gnu: python-tldr: Update to 3.1.0.
* gnu/packages/python-xyz.scm (python-tldr): Update to 3.1.0. [phases]: Add phase to build docs. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/python-xyz.scm11
1 files changed, 7 insertions, 4 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index ea1261d17e..ddb7e9b0bb 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -23982,7 +23982,7 @@ Public Suffix List's private domains as well.")
(define-public python-tldr
(package
(name "python-tldr")
- (version "1.2.1")
+ (version "3.1.0")
(source
(origin
;; There's no test in PyPI.
@@ -23992,20 +23992,23 @@ Public Suffix List's private domains as well.")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "0n9wqvjxspm18vlxf9j9slrcydshk4rkv5nwkrqhfq606n6zvks4"))))
+ (base32 "1hxmprqg8c4cvs19n7f80f3y7jj74i8sc2dmq2gdjmsdrb54bbzc"))))
(build-system python-build-system)
(arguments
`(#:phases
(modify-phases %standard-phases
+ (add-after 'build 'build-doc
+ (lambda _
+ (invoke "make" "-C" "docs")))
(replace 'check
(lambda* (#:key tests? #:allow-other-keys)
(when tests?
;; This test fails. It tries to open a network socket.
(invoke "pytest" "-vv" "-k" "not test_error_message")))))))
(native-inputs
- (list python-pytest python-pytest-runner))
+ (list python-pytest python-pytest-runner python-sphinx-argparse))
(inputs
- (list python-argcomplete python-colorama python-termcolor))
+ (list python-argcomplete python-colorama python-termcolor python-shtab))
(home-page "https://github.com/tldr-pages/tldr-python-client")
(synopsis "Python command-line client for tldr pages")
(description "This package provides the @code{tldr} command allowing users