summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-04-08 23:37:37 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-04-10 20:54:18 +0200
commit145d1f39db553fd138bc21936a6f3e97aebc3028 (patch)
tree27cd354bc7d392831fa338254af3e63143597226
parent339eef40f85a08609bb711557a67945173b490cb (diff)
downloadguix-patches-145d1f39db553fd138bc21936a6f3e97aebc3028.tar
guix-patches-145d1f39db553fd138bc21936a6f3e97aebc3028.tar.gz
gnu: emacs-parent-mode: Don't use unstable tarball.
* gnu/packages/emacs-xyz.scm (emacs-parent-mode)[source]: Use GIT-FETCH and GIT-FILE-NAME.
-rw-r--r--gnu/packages/emacs-xyz.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index b306a03a06..87fe988312 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -9978,13 +9978,13 @@ until the top-level form is no longer a macro call.")
(version "2.3")
(source
(origin
- (method url-fetch)
- (uri (string-append "https://github.com/Fanael/parent-mode/archive/"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Fanael/parent-mode.git")
+ (commit version)))
+ (file-name (git-file-name name version))
(sha256
- (base32
- "0gxbl5s1w96v6v55b7aaansgw4sxhzfx9nrsvpk3pfhsibs6yqjd"))))
+ (base32 "0i5bc7lyyrx6swqlrp9l5x72yzwi53qn6ldrfs99gh08b3yvsnni"))))
(build-system emacs-build-system)
(home-page "https://github.com/Fanael/parent-mode")
(synopsis "Get major mode's parent modes")