summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoseph LaFreniere <joseph@lafreniere.xyz>2020-07-26 11:06:19 -0500
committerLudovic Courtès <ludo@gnu.org>2020-09-19 22:52:37 +0200
commitcfcccc8a2afd13eaf103098e4d1611cef3b7123e (patch)
treed828d9648d449ca1b9e1ec2599458f9988d89bb9
parent1b179d7876f19f04009a2f9e248ac10711f4c660 (diff)
downloadguix-patches-cfcccc8a2afd13eaf103098e4d1611cef3b7123e.tar
guix-patches-cfcccc8a2afd13eaf103098e4d1611cef3b7123e.tar.gz
gnu: Add emacs-standard-dirs.
* gnu/packages/emacs-xyz.scm (emacs-standard-dirs): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/emacs-xyz.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 15f24cda5d..d47b1ca36e 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -3792,6 +3792,30 @@ particular, the minor mode works quite well with Org or Markdown modes, or
other markup language major modes.")
(license license:gpl3+))))
+(define-public emacs-standard-dirs
+ (package
+ (name "emacs-standard-dirs")
+ (version "2.0.0")
+ (home-page "https://github.com/lafrenierejm/standard-dirs.el")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0r814qcrhvx4qlx4sdzwdmrhiryslqclx0bnpp0qcrbx6g8qfl25"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-f" ,emacs-f)
+ ("emacs-s" ,emacs-s)))
+ (synopsis "Platform-specific paths for config, cache, and other data")
+ (description
+ "This package provides platform-specific paths for reading and writing
+configuration, cache, and other data.")
+ (license license:gpl3+)))
+
(define-public emacs-string-inflection
(package
(name "emacs-string-inflection")