summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2015-12-22 22:15:09 +0100
committerRicardo Wurmus <rekado@elephly.net>2015-12-24 10:10:40 +0100
commitbaeab9b8b960105e91d8b8ef5a0851dc9f4e99bd (patch)
tree5e6beb0192b2c70ec597fc11a6ff51cf56af5cfd
parentc1d41b5df33a164b0bbfd0dbb9bdb897ee473660 (diff)
downloadguix-patches-baeab9b8b960105e91d8b8ef5a0851dc9f4e99bd.tar
guix-patches-baeab9b8b960105e91d8b8ef5a0851dc9f4e99bd.tar.gz
gnu: Add XML::Compile::SOAP.
* gnu/packages/xml.scm (perl-xml-compile-soap): New variable.
-rw-r--r--gnu/packages/xml.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index 7eada2bcbb..c534de44e6 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -467,6 +467,34 @@ a schema.")
"This package provides methods to cache compiled XML translators.")
(license (package-license perl))))
+(define-public perl-xml-compile-soap
+ (package
+ (name "perl-xml-compile-soap")
+ (version "3.13")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cpan/authors/id/M/MA/MARKOV/"
+ "XML-Compile-SOAP-" version ".tar.gz"))
+ (sha256
+ (base32
+ "08qw63l78040nh37xzapbqp43g6s5l67bvskf3dyyizlarjx5mi4"))))
+ (build-system perl-build-system)
+ (propagated-inputs
+ `(("perl-file-slurp-tiny" ,perl-file-slurp-tiny)
+ ("perl-libwww" ,perl-libwww)
+ ("perl-log-report" ,perl-log-report)
+ ("perl-xml-compile" ,perl-xml-compile)
+ ("perl-xml-compile-cache" ,perl-xml-compile-cache)
+ ("perl-xml-compile-tester" ,perl-xml-compile-tester)))
+ (home-page "http://search.cpan.org/dist/XML-Compile-SOAP")
+ (synopsis "Base-class for SOAP implementations")
+ (description
+ "This module provides a class to handle the SOAP protocol. The first
+implementation is @url{SOAP1.1,
+http://www.w3.org/TR/2000/NOTE-SOAP-20000508/}, which is still most often
+used.")
+ (license (package-license perl))))
+
(define-public pugixml
(package
(name "pugixml")