summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2015-12-22 16:04:50 +0100
committerRicardo Wurmus <rekado@elephly.net>2015-12-24 10:10:40 +0100
commit8aad646637566d8468ae1154407539f8f83a91d6 (patch)
treea0d60d3fc82714e18d86427de21d758aaba0e9fd
parenta05996e00094caecd87fea4f59fb07cd9b2cc656 (diff)
downloadguix-patches-8aad646637566d8468ae1154407539f8f83a91d6.tar
guix-patches-8aad646637566d8468ae1154407539f8f83a91d6.tar.gz
gnu: Add File::Slurp::Tiny.
* gnu/packages/perl.scm (perl-file-slurp-tiny): New variable.
-rw-r--r--gnu/packages/perl.scm18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index bac20ef8b4..6c0b4d2f6c 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -2344,6 +2344,24 @@ files with a simple call. It also has a subroutine for reading the list of
file names in a directory.")
(license (package-license perl))))
+(define-public perl-file-slurp-tiny
+ (package
+ (name "perl-file-slurp-tiny")
+ (version "0.004")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cpan/authors/id/L/LE/LEONT/"
+ "File-Slurp-Tiny-" version ".tar.gz"))
+ (sha256
+ (base32
+ "07kzfmibl43dq4c803f022g2rcfv4nkjgipxclz943mzxaz9aaa5"))))
+ (build-system perl-build-system)
+ (home-page "http://search.cpan.org/dist/File-Slurp-Tiny")
+ (synopsis "Simple file reader and writer")
+ (description
+ "This module provides functions for fast reading and writing of files.")
+ (license (package-license perl))))
+
(define-public perl-file-temp
(package
(name "perl-file-temp")