summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-06-24 23:47:42 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-06-26 22:10:39 -0400
commit76de731b4ba89884d7792e87f9feb63474c9a260 (patch)
tree2aa91f12067a31c8b69125e3b041576cac09d734
parent61b509aec6e42edfb6a6f12f991d06c85eb46351 (diff)
downloadguix-patches-76de731b4ba89884d7792e87f9feb63474c9a260.tar
guix-patches-76de731b4ba89884d7792e87f9feb63474c9a260.tar.gz
gnu: python-immutables: Update to 0.18.
* gnu/packages/python-xyz.scm (python-immutables): Update to 0.18. [native-inputs]: Add python-mypy, python-pytest.
-rw-r--r--gnu/packages/python-xyz.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index f2c1f0bb99..8cb9cb4c6a 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -11522,14 +11522,15 @@ distribution. It is not intended as an end-user tool.")
(define-public python-immutables
(package
(name "python-immutables")
- (version "0.14")
+ (version "0.18")
(source
(origin
(method url-fetch)
(uri (pypi-uri "immutables" version))
(sha256
- (base32 "0y0aqw29g525frdnmv9paljzacpp4s21sadfbca5b137iciwr8d0"))))
+ (base32 "1x4cinh0xbl6p6p2yfm2s07mxxy3lf0zzai9gqpydk4482bwfdjk"))))
(build-system python-build-system)
+ (native-inputs (list python-mypy python-pytest))
(home-page "https://github.com/MagicStack/immutables")
(synopsis "High-performance immutable mapping type for Python")
(description