summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2019-08-26 10:00:26 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2019-08-26 10:00:26 +0200
commit6643642482c6fabf6bebae3a5bdf576723b2099c (patch)
tree115e8c1811d587c42c5dc2dada53a5ede4b43a77
parenta707484d64e7e46f8cb8401c660fbb6eb77ab9c6 (diff)
downloadguix-patches-6643642482c6fabf6bebae3a5bdf576723b2099c.tar
guix-patches-6643642482c6fabf6bebae3a5bdf576723b2099c.tar.gz
gnu: Add python-pyroutelib3.
* gnu/packages/python-xyz.scm (python-pyroutelib3): New variable.
-rw-r--r--gnu/packages/python-xyz.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 40e6a01dd7..ee17bf78e2 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -16114,3 +16114,22 @@ to deduct the desired information. This data can be parsed by automatic pre-
and post-processing scripts that draw information and store it more densely
for manual interpretation.")
(license license:gpl3+)))
+
+(define-public python-pyroutelib3
+ (package
+ (name "python-pyroutelib3")
+ (version "1.3.post1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pyroutelib3" version))
+ (sha256
+ (base32
+ "1hpbydpn2alyswiajfbvhzq4c7f36vdmvxy91hgv8l1lb2g2vfrj"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-dateutil" ,python-dateutil)))
+ (home-page "https://github.com/MKuranowski/pyroutelib3")
+ (synopsis "Library for simple routing on OSM data")
+ (description "Library for simple routing on OSM data")
+ (license license:gpl3+)))