summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-06-29 12:27:35 +0200
committerRicardo Wurmus <rekado@elephly.net>2021-06-29 12:28:44 +0200
commitae00ea94aa14097c61b15cbac016baeacdd1113a (patch)
treef3411a3417753627728c6ae33d16d46ee4672c31
parent1be97fa9ced3a165704631bbcf93835b45a5ea4d (diff)
downloadguix-patches-ae00ea94aa14097c61b15cbac016baeacdd1113a.tar
guix-patches-ae00ea94aa14097c61b15cbac016baeacdd1113a.tar.gz
gnu: Add r-mlapi.
* gnu/packages/cran.scm (r-mlapi): New variable.
-rw-r--r--gnu/packages/cran.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index c2785e5d01..ed834985cf 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -17810,6 +17810,33 @@ they are often difficult to interpret. Rex allows you to build complex
regular expressions from human readable expressions")
(license license:expat)))
+(define-public r-mlapi
+ (package
+ (name "r-mlapi")
+ (version "0.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "mlapi" version))
+ (sha256
+ (base32
+ "023vk5bp8cjcq88sapkl87kdxr92bay1dyxl6xirnyj699pyj51k"))))
+ (properties `((upstream-name . "mlapi")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-matrix" ,r-matrix)
+ ("r-r6" ,r-r6)))
+ (native-inputs
+ `(("r-knitr" ,r-knitr)))
+ (home-page "https://cran.r-project.org/package=mlapi")
+ (synopsis "Abstract classes for building scikit-learn like API")
+ (description
+ "This package provides R6 abstract classes for building machine learning
+models with a scikit-learn like API. Scikit-learn is a popular module for the
+Python programming language whose design became a de facto standard in
+industry for machine learning tasks.")
+ (license license:expat)))
+
(define-public r-xmlparsedata
(package
(name "r-xmlparsedata")