summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Leung <bkleung89@gmail.com>2019-03-15 03:38:34 +0100
committerOleg Pykhalov <go.wigust@gmail.com>2019-03-16 13:59:28 +0300
commita6718145265787e39bd0c703d22eb8846464fbec (patch)
tree9e018372cb257fecbee08d4631d378b9313f8fa5
parentd82bd2034884c5037065c48d5eefe0acd2768e30 (diff)
downloadguix-patches-a6718145265787e39bd0c703d22eb8846464fbec.tar
guix-patches-a6718145265787e39bd0c703d22eb8846464fbec.tar.gz
gnu: Add emacs-editorconfig.
* gnu/packages/emacs-xyz.scm (emacs-editorconfig): New variable. Signed-off-by: Oleg Pykhalov <go.wigust@gmail.com>
-rw-r--r--gnu/packages/emacs-xyz.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 28f86fd709..e10a6627a6 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -12466,6 +12466,30 @@ execute its commands and resize images.")
backends, including the @command{wordnet} offline backend.")
(license license:gpl3+))))
+(define-public emacs-editorconfig
+ (package
+ (name "emacs-editorconfig")
+ (version "0.7.14")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/editorconfig/editorconfig-emacs")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "19j2428ij7sqvrqs7rqg1mcnv9109y6drqba40dkv3vrkk5d2yia"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/editorconfig/editorconfig-emacs")
+ (synopsis "Define and maintain consistent coding styles between different
+editors and IDEs")
+ (description "The EditorConfig project consists of a file format for
+defining coding styles and a collection of text editor plugins that enable
+editors to read the file format and adhere to defined styles. EditorConfig
+files are easily readable and they work nicely with version control systems.")
+ (license license:gpl3+)))
+
(define-public emacs-all-the-icons
(package
(name "emacs-all-the-icons")