summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2020-06-06 15:10:45 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2020-06-06 15:10:45 +0200
commit7b32e7bfafe40f0ef9158f823a73e33173291ab8 (patch)
tree8d6f936fd14561961d1820ffcb544cbf3fdbb865
parentdc81932ee5883c7c90e1bfd0f57b0321f4f183f9 (diff)
downloadguix-patches-7b32e7bfafe40f0ef9158f823a73e33173291ab8.tar
guix-patches-7b32e7bfafe40f0ef9158f823a73e33173291ab8.tar.gz
gnu: emacs-posframe: Update to 0.7.0.
* gnu/packages/emacs-xyz.scm (emacs-posframe): Update to 0.7.0. [source]: Use GNU Elpa repository instead of GitHub.
-rw-r--r--gnu/packages/emacs-xyz.scm18
1 files changed, 8 insertions, 10 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 4ccbc14a23..f207cebb71 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -10322,20 +10322,18 @@ and cangjie.")
(define-public emacs-posframe
(package
(name "emacs-posframe")
- (version "0.5.0")
+ (version "0.7.0")
(source
(origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/tumashu/posframe")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
+ (method url-fetch)
+ (uri (string-append "https://elpa.gnu.org/packages/"
+ "posframe-" version ".el"))
(sha256
- (base32
- "1fhjxj7gi2pj5rdnmf0gddiwd8iifgjgjp01c01npz1gwwixyqh3"))))
+ (base32 "1kwl83jb5k1hnx0s2qw972v0gjqbbvk4sdcdb1qbdxsyw36sylc9"))))
(build-system emacs-build-system)
- ;; emacs-minimal does not include the function font-info
- (arguments `(#:emacs ,emacs))
+ ;; emacs-minimal does not include the function font-info.
+ (arguments
+ `(#:emacs ,emacs))
(home-page "https://github.com/tumashu/posframe")
(synopsis "Pop a posframe (a child frame) at point")
(description "@code{emacs-posframe} can pop a posframe at point. A