summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2020-06-06 15:14:25 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2020-06-06 15:14:25 +0200
commit678248f5ea3d3d19bc2a5a41d90bb30e63e667e1 (patch)
treed8ce654d69e536517c993f98b20641ea5937211e
parent7b32e7bfafe40f0ef9158f823a73e33173291ab8 (diff)
downloadguix-patches-678248f5ea3d3d19bc2a5a41d90bb30e63e667e1.tar
guix-patches-678248f5ea3d3d19bc2a5a41d90bb30e63e667e1.tar.gz
gnu: emacs-stream: Update to 2.2.5.
* gnu/packages/emacs-xyz.scm (emacs-stream): Update to 2.2.5. [source]: Use GNU ELPA repository instead of GitHub. [arguments]: Skip tests, which do not exist on ELPA.
-rw-r--r--gnu/packages/emacs-xyz.scm40
1 files changed, 16 insertions, 24 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index f207cebb71..94d2620056 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -9139,31 +9139,23 @@ editing nginx config files.")
(license license:gpl2+)))
(define-public emacs-stream
- (let ((commit "a3f3da155a49c133e2692bd8789b35492bfdc4f7")
- (revision "1"))
- (package
- (name "emacs-stream")
- (version (git-version "2.2.4" revision commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/Emacsmirror/stream.git")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32 "0aig0yjb9z752ijh0mzildjmh44j051inchga8qll01dr8wf7332"))))
- (build-system emacs-build-system)
- (arguments
- `(#:tests? #t
- #:test-command '("emacs" "--batch"
- "-l" "tests/stream-tests.el"
- "-f" "ert-run-tests-batch-and-exit")))
- (home-page "https://github.com/Emacsmirror/stream")
- (synopsis "Implementation of streams for Emacs")
- (description "This library provides an implementation of streams for Emacs.
+ (package
+ (name "emacs-stream")
+ (version "2.2.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://elpa.gnu.org/packages/"
+ "stream-" version ".tar"))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "00c3n4gyxzv7vczqms0d62kl8zsmjfyxa92mwxn2snyx857a9jfw"))))
+ (build-system emacs-build-system)
+ (home-page "http://elpa.gnu.org/packages/stream.html")
+ (synopsis "Implementation of streams for Emacs")
+ (description "This library provides an implementation of streams for Emacs.
Streams are implemented as delayed evaluation of cons cells.")
- (license license:gpl3+))))
+ (license license:gpl3+)))
(define-public emacs-cl-print
(let ((commit "1a70c553dfb04352afb5b8696fe0cef8acc8f991")