summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-09-15 22:50:25 +0200
committerRicardo Wurmus <rekado@elephly.net>2019-09-15 22:50:25 +0200
commitd6a5d9b24f30d35b41f76053be2b826b8d63815d (patch)
tree9bc2165525ea604b98961fe51a6fad96544c33ae
parentdf8576e5c93e765fc4f75c47698342b1f7aa9642 (diff)
downloadguix-patches-d6a5d9b24f30d35b41f76053be2b826b8d63815d.tar
guix-patches-d6a5d9b24f30d35b41f76053be2b826b8d63815d.tar.gz
gnu: Add r-affxparser.
* gnu/packages/bioconductor.scm (r-affxparser): New variable.
-rw-r--r--gnu/packages/bioconductor.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 4f2d97025a..b60c5d8ef2 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -1116,6 +1116,34 @@ problems in CEL-level data to help evaluate performance of quality metrics.")
to streamline the more common analyses that a Biostatistician might see.")
(license license:artistic2.0)))
+(define-public r-affxparser
+ (package
+ (name "r-affxparser")
+ (version "1.56.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "affxparser" version))
+ (sha256
+ (base32
+ "1jv7k9pn4c7szi3ma2f2xsd58pkrkvjpk5wra73r6kc607qgrv33"))))
+ (properties `((upstream-name . "affxparser")))
+ (build-system r-build-system)
+ (home-page "https://github.com/HenrikBengtsson/affxparser")
+ (synopsis "Affymetrix File Parsing SDK")
+ (description
+ "This is a package for parsing Affymetrix files (CDF, CEL, CHP, BPMAP,
+BAR). It provides methods for fast and memory efficient parsing of Affymetrix
+files using the Affymetrix' Fusion SDK. Both ASCII- and binary-based files
+are supported. Currently, there are methods for reading @dfn{chip definition
+file} (CDF) and a @dfn{cell intensity file} (CEL). These files can be read
+either in full or in part. For example, probe signals from a few probesets
+can be extracted very quickly from a set of CEL files into a convenient list
+structure.")
+ ;; The Fusion SDK contains files under GPLv2 and LGPLv2.1. The R code is
+ ;; under LGPLv2+.
+ (license (list license:lgpl2.0+ license:lgpl2.1 license:gpl2))))
+
(define-public r-annotate
(package
(name "r-annotate")