summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre Langlois <pierre.langlois@gmx.com>2020-12-28 10:49:19 +0000
committerPierre Langlois <pierre.langlois@gmx.com>2020-12-28 16:31:07 +0000
commitcd11f6a2bd703f0859aec05c0873186b734d6d74 (patch)
tree31991a03ca4a5ab0e48537c2ff05f58438ce66e4
parent1be0da2c7bb30e8c56d5cc82276ff6621802dacd (diff)
downloadguix-patches-cd11f6a2bd703f0859aec05c0873186b734d6d74.tar
guix-patches-cd11f6a2bd703f0859aec05c0873186b734d6d74.tar.gz
gnu: emacs-org: Work around missing version number.
Partly fixes <https://bugs.gnu.org/45448>. * gnu/packages/emacs-xyz.scm (emacs-org)[arguments]: New 'fix-org-version phase.
-rw-r--r--gnu/packages/emacs-xyz.scm9
1 files changed, 9 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index eaa0fc8d2a..f85ae60cb6 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -10296,6 +10296,15 @@ passive voice.")
(arguments
`(#:phases
(modify-phases %standard-phases
+ ;; FIXME: The elpa tarball upstream does not include the version
+ ;; number, remove this phase when this is fixed.
+ ;; https://lists.gnu.org/archive/html/emacs-orgmode/2020-12/msg00729.html
+ (add-after 'unpack 'fix-org-version
+ (lambda _
+ (substitute* "org-version.el"
+ (("org-release \"\"")
+ (string-append "org-release \"" ,version "\"")))
+ #t))
(add-after 'install 'install-documentation
(lambda* (#:key outputs #:allow-other-keys)
(let* ((share (string-append (assoc-ref outputs "out") "/share"))