summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSughosha <sughosha@proton.me>2022-06-22 08:09:28 +0200
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2022-06-26 16:56:20 +0200
commitb7a091cf7fe130b267e65fbc9101972f0291b431 (patch)
tree74cd8f289e5d35ab20be68ec3375ea1d6ac640b7
parent33536ff4388b40ba3e2cdd38720ce7a2aa72d3e2 (diff)
downloadguix-patches-b7a091cf7fe130b267e65fbc9101972f0291b431.tar
guix-patches-b7a091cf7fe130b267e65fbc9101972f0291b431.tar.gz
gnu: Add gnome-shell-extension-transparent-window.
* gnu/packages/gnome-xyz.scm (gnome-shell-extension-transparent-window): New variable. Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
-rw-r--r--gnu/packages/gnome-xyz.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index 35e5969775..da316186d5 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -1051,6 +1051,37 @@ in the status menu below the volume slider. Various active ports like HDMI,
Speakers etc. of the same device are also displayed for selection.")
(license license:gpl3+)))
+(define-public gnome-shell-extension-transparent-window
+ (let ((commit "cc9bc70c192dd565fa6f1d1b28d9a20f99684f2a")
+ (revision "45"))
+ (package
+ (name "gnome-shell-extension-transparent-window")
+ (version (git-version "0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url (string-append "https://github.com/pbxqdown/"
+ "gnome-shell-extension-transparent-window"))
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1f9iqqjpmmylqz0ws8cy5rs475bwzi7jy44q9ip44ig2acz2wxzp"))))
+ (build-system copy-build-system)
+ (arguments
+ (list
+ #:install-plan
+ #~'(("."
+ #$(string-append "/share/gnome-shell/extensions"
+ "/transparent-window@pbxqdown.github.com")))))
+ (home-page
+ "https://github.com/pbxqdown/gnome-shell-extension-transparent-window")
+ (synopsis "Change the opacity of windows in GNOME Shell")
+ (description "This extension adds keybindings to change the opacity
+of windows.")
+ (license license:expat))))
+
(define-public arc-theme
(package
(name "arc-theme")