summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-05-20 16:48:13 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-05-20 17:12:25 +0300
commita9db2df4dd0a11b8461d57dfd0029d73e4290a57 (patch)
tree2c8548db03ee22e02805dd3183d2285e43192493
parentdd331f491db93d2854c591bd4f9160b565671408 (diff)
downloadguix-patches-a9db2df4dd0a11b8461d57dfd0029d73e4290a57.tar
guix-patches-a9db2df4dd0a11b8461d57dfd0029d73e4290a57.tar.gz
gnu: Add julia-crayons.
* gnu/packages/julia-xyz.scm (julia-crayons): New variable.
-rw-r--r--gnu/packages/julia-xyz.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index 4a4be83889..dc2d0336a0 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -423,6 +423,28 @@ build tree Yggdrasil.")
for construction of objects.")
(license license:expat)))
+(define-public julia-crayons
+ (package
+ (name "julia-crayons")
+ (version "4.0.4")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/KristofferC/Crayons.jl")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0v3zhjlnb2914bxcj4myl8pgb7m31p77aj2k1bckmqs96jdph10z"))))
+ (build-system julia-build-system)
+ (home-page "https://github.com/KristofferC/Crayons.jl")
+ (synopsis "Colored and styled strings for terminals")
+ (description "Crayons is a package that makes it simple to write strings in
+different colors and styles to terminals. It supports the 16 system colors,
+both the 256 color and 24 bit true color extensions, and the different text
+styles available to terminals.")
+ (license license:expat)))
+
(define-public julia-datastructures
(package
(name "julia-datastructures")