summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGiacomo Leidi <goodoldpaul@autistici.org>2019-08-14 19:23:02 +0200
committerLudovic Courtès <ludo@gnu.org>2019-08-16 23:00:27 +0200
commita830d14d4be2f81192e49a91a21a15121808e0a8 (patch)
treed6357594c6074987e14e0a60b64693c90e7a49f7
parent7d30b58808e17fd194000c8bde10c5e8b30d5af0 (diff)
downloadguix-patches-a830d14d4be2f81192e49a91a21a15121808e0a8.tar
guix-patches-a830d14d4be2f81192e49a91a21a15121808e0a8.tar.gz
gnu: Add libgit2-glib.
* gnu/packages/gnome.scm (libgit2-glib): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/gnome.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index da6cbf2a05..d5e46e09c1 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -8283,3 +8283,35 @@ advanced image management tool")
(description "The aim of the handy library is to help with developing user
intefaces for mobile devices using GTK+.")
(license license:lgpl2.1+)))
+
+(define-public libgit2-glib
+ (package
+ (name "libgit2-glib")
+ (version "0.28.0.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/" name "/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "0a0g7aw66rfgnqr4z7fgbk5zzcjq66m4rp8v4val3a212941h0g7"))))
+ (build-system meson-build-system)
+ (native-inputs
+ `(("glib:bin" ,glib "bin") ;; For glib-mkenums
+ ("gobject-introspection" ,gobject-introspection)
+ ("intltool" ,intltool)
+ ("libssh2" ,libssh2)
+ ("pkg-config" ,pkg-config)
+ ("python-pygobject" ,python-pygobject)
+ ("python-wrapper" ,python-wrapper)
+ ("vala" ,vala)))
+ (inputs
+ `(("glib" ,glib)
+ ("libgit2" ,libgit2)))
+ (synopsis "GLib wrapper around the libgit2 Git access library")
+ (description "libgit2-glib is a GLib wrapper library around the libgit2 Git
+access library. It only implements the core plumbing functions, not really the
+higher level porcelain stuff.")
+ (home-page "https://wiki.gnome.org/Projects/Libgit2-glib")
+ (license license:gpl2+)))