summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStephen Paul Weber <singpolyma@singpolyma.net>2022-06-26 13:11:59 -0400
committerRaghav Gururajan <rg@raghavgururajan.name>2022-06-26 13:43:31 -0400
commita105975119e6902cf1df12813fe6e06b254f70fd (patch)
treef4b292b48256f6c08ed1dc0b7fa5e0195ec6b19b
parent4009c98e5a4c03a523fa58f71016e2b053c5952b (diff)
downloadguix-patches-a105975119e6902cf1df12813fe6e06b254f70fd.tar
guix-patches-a105975119e6902cf1df12813fe6e06b254f70fd.tar.gz
gnu: Add ruby-nori.
* gnu/packages/ruby.scm (ruby-nori): New variable. Signed-off-by: Raghav Gururajan <rg@raghavgururajan.name>
-rw-r--r--gnu/packages/ruby.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 4ba14f9adf..15e3c1ca2c 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -12687,3 +12687,28 @@ using published rates from open-exchange-rates. Compatible with the money gem."
(description "Roda is a routing tree web toolkit, designed for building fast
and maintainable web applications in ruby.")
(license license:expat)))
+
+(define-public ruby-nori
+ (package
+ (name "ruby-nori")
+ (version "2.6.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "nori" version))
+ (sha256
+ (base32 "066wc774a2zp4vrq3k7k8p0fhv30ymqmxma1jj7yg5735zls8agn"))))
+ (build-system ruby-build-system)
+ (arguments
+ ;; Tests require too old version of rspec
+ `(#:tests? #f))
+ (native-inputs
+ (list ruby-nokogiri
+ ruby-rake
+ ruby-rspec))
+ (home-page "https://github.com/savonrb/nori")
+ (synopsis "XML to Hash translator")
+ (description "Nori is a simple XML parsing ripped from Crack which in-turn
+ripped from Merb. It supports pluggable parsers and ships with both REXML and
+Nokogiri implementations.")
+ (license license:expat)))