summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAntero Mejr <antero@mailbox.org>2022-06-25 04:25:03 +0000
committerLudovic Courtès <ludo@gnu.org>2022-06-26 23:19:14 +0200
commit8d0e69624357c0ce9e7c0b0713910a3e35f16226 (patch)
treed35d738692f267cbe0547b1f6dda3ab2ccebb573
parent24dba9c5e78c3586a8b53296b59b41cf1f82817f (diff)
downloadguix-patches-8d0e69624357c0ce9e7c0b0713910a3e35f16226.tar
guix-patches-8d0e69624357c0ce9e7c0b0713910a3e35f16226.tar.gz
gnu: Add python-sendgrid.
* gnu/packages/python-web.scm (python-sendgrid): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/python-web.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 088d7eb3d2..e48e4773df 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -7569,3 +7569,28 @@ resources using Web Application Description Language (WADL) files as guides.")
(description
"This package provides access to any RESTful or RESTful-like API.")
(license license:expat)))
+
+(define-public python-sendgrid
+ (package
+ (name "python-sendgrid")
+ (version "6.9.7")
+ (home-page "https://github.com/sendgrid/sendgrid-python/")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0kvp4gm3bpcsj2mkv05pgvlcv1jlsfhcljcv61wz5kq9d273h7rg"))))
+ (build-system python-build-system)
+ (arguments
+ (list #:tests? #f)) ;241/340 tests fail due to attempted web access
+ (propagated-inputs (list python-http-client python-starkbank-ecdsa))
+ (synopsis "SendGrid API library for Python")
+ (description
+ "The @code{sendgrid} Python library allows access to the
+SendGrid Web API v3. Version 3+ of the library provides full support for all
+SendGrid Web API v3 endpoints, including the new v3 /mail/send.")
+ (license license:expat)))