summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2018-10-02 16:29:25 -0400
committerLeo Famulari <leo@famulari.name>2018-10-02 16:30:25 -0400
commit63781c5748b108db5ceab02ce2d201e901ff10a4 (patch)
tree97411455ff69f08005ef0a4e338d08f7b8db7d34
parent9c1c2108a5523015fd83e599b263dfb1ad348324 (diff)
downloadguix-patches-63781c5748b108db5ceab02ce2d201e901ff10a4.tar
guix-patches-63781c5748b108db5ceab02ce2d201e901ff10a4.tar.gz
gnu: Add r-acclma.
* gnu/packages/cran.scm (r-acclma): New variable.
-rw-r--r--gnu/packages/cran.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 52b3d52bac..a1bf750da6 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -6228,3 +6228,31 @@ measured by the probability of acceptance for a given level of quality in the
lot.")
(license license:gpl3+)))
+(define-public r-acclma
+ (package
+ (name "r-acclma")
+ (version "1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "ACCLMA" version))
+ (sha256
+ (base32 "1na27sp18fq12gp6vxgqw1ffsz2yi1d8xvrxbrzx5g1kqxrayy0v"))))
+ (properties `((upstream-name . "ACCLMA")))
+ (build-system r-build-system)
+ (home-page "https://cran.r-project.org/web/packages/ACCLMA/")
+ (synopsis "ACC & LMA graph plotting")
+ (description
+ "This package contains a function that imports data from a @acronym{Comma-Separated
+Values, @acronym{CSV}} file, or uses manually entered data from the format (x,
+y, weight) and plots the appropriate @acronym{Absolute Concentration Curve,
+@acronym{ACC}} vs @acronym{Line of Independence, @acronym{LOI}} graph and
+@acronym{@acronym{LOI} Minus @acronym{ACC}, @acronym{LMA}} graph. The main
+function is plotLMA (source file, header) that takes a data set and plots the
+appropriate @acronym{LMA} and @acronym{ACC} graphs. If no source file (a
+string) was passed, a manual data entry window is opened. The header parameter
+indicates by TRUE/FALSE (false by default) if the source @acronym{CSV} file has
+a header row or not. The dataset should contain only one independent variable
+(x) and one dependent variable (y) and can contain a weight for each
+observation.")
+ (license license:gpl2)))