summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-09-27 08:41:19 +0200
committerLudovic Courtès <ludo@gnu.org>2013-09-27 08:41:19 +0200
commit5c413a9cbc89c200d4450fc8ff21507e6659fdd5 (patch)
treeadbce42e02a0b991429b5532e77e41890602837f
parent6bf3e5f72d2fdaaa092a03d78e44c46e41b60241 (diff)
downloadguix-patches-5c413a9cbc89c200d4450fc8ff21507e6659fdd5.tar
guix-patches-5c413a9cbc89c200d4450fc8ff21507e6659fdd5.tar.gz
gnu: module-init-tools: Remove reference to unavailable man page tarball.
Fixes <http://bugs.gnu.org/15187>. Reported by Mark H. Weaver <mhw@netris.org>. * gnu/packages/linux.scm (module-init-tools): Remove reference to Gentoo's pre-built man pages and 'unpack-man-pages' phase. Add 'fake-docbook' phases.
-rw-r--r--gnu/packages/linux.scm24
1 files changed, 8 insertions, 16 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 06b0b6da99..9d0b93d406 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -122,24 +122,16 @@
(base32
"0jxnz9ahfic79rp93l5wxcbgh4pkv85mwnjlbv1gz3jawv5cvwp1"))))
(build-system gnu-build-system)
- (inputs
- ;; The upstream tarball lacks man pages, and building them would require
- ;; DocBook & co. Thus, use Gentoo's pre-built man pages.
- `(("man-pages"
- ,(origin
- (method url-fetch)
- (uri (string-append
- "http://distfiles.gentoo.org/distfiles/module-init-tools-" version
- "-man.tar.bz2"))
- (sha256
- (base32
- "1j1nzi87kgsh4scl645fhwhjvljxj83cmdasa4n4p5krhasgw358"))))))
(arguments
+ ;; FIXME: The upstream tarball lacks man pages, and building them would
+ ;; require DocBook & co. We used to use Gentoo's pre-built man pages,
+ ;; but they vanished. In the meantime, fake it.
'(#:phases (alist-cons-before
- 'unpack 'unpack-man-pages
- (lambda* (#:key inputs #:allow-other-keys)
- (let ((man-pages (assoc-ref inputs "man-pages")))
- (zero? (system* "tar" "xvf" man-pages))))
+ 'configure 'fake-docbook
+ (lambda _
+ (substitute* "Makefile.in"
+ (("^DOCBOOKTOMAN.*$")
+ "DOCBOOKTOMAN = true\n")))
%standard-phases)))
(home-page "http://www.kernel.org/pub/linux/utils/kernel/module-init-tools/")
(synopsis "Tools for loading and managing Linux kernel modules")