summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2018-08-14 11:10:35 +0200
committerRicardo Wurmus <rekado@elephly.net>2018-08-14 11:28:52 +0200
commit4646d18eb769691224d25ead7da416b5f8783529 (patch)
tree412dd54902967e520d83ff4f6c637379625797d2
parent3d4908a77b3c557418d95152edb2f1bff93bf09d (diff)
downloadguix-patches-4646d18eb769691224d25ead7da416b5f8783529.tar
guix-patches-4646d18eb769691224d25ead7da416b5f8783529.tar.gz
gnu: Add r-hash.
* gnu/packages/cran.scm (r-hash): New variable.
-rw-r--r--gnu/packages/cran.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 106b8c7fe6..b491cc7eb2 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -4615,3 +4615,24 @@ matches version and feature constraints.")
write shebang scripts that gracefully accept positional and optional arguments
and automatically generate usage notices.")
(license license:gpl2+)))
+
+(define-public r-hash
+ (package
+ (name "r-hash")
+ (version "2.2.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "hash" version))
+ (sha256
+ (base32
+ "0mkx59bmni3b283znvbndnkbar85fzavzdfgmwrhskidsqcz34yz"))))
+ (build-system r-build-system)
+ (home-page "https://cran.r-project.org/web/packages/hash/")
+ (synopsis "Implementation of hash/associated arrays/dictionaries")
+ (description
+ "This package implements a data structure similar to hashes in Perl and
+dictionaries in Python but with a purposefully R flavor. For objects of
+appreciable size, access using hashes outperforms native named lists and
+vectors.")
+ (license license:gpl2+)))