summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStephen Paul Weber <singpolyma@singpolyma.net>2022-06-26 12:53:52 -0400
committerRaghav Gururajan <rg@raghavgururajan.name>2022-06-26 13:43:31 -0400
commit4009c98e5a4c03a523fa58f71016e2b053c5952b (patch)
tree18f26b9a287e088d8d959b2532bf319047be1778
parentcbf02f10d7264d14accdc16b522077c8f857240f (diff)
downloadguix-patches-4009c98e5a4c03a523fa58f71016e2b053c5952b.tar
guix-patches-4009c98e5a4c03a523fa58f71016e2b053c5952b.tar.gz
gnu: Add ruby-roda.
* gnu/packages/ruby.scm (ruby-roda): New variable. Signed-off-by: Raghav Gururajan <rg@raghavgururajan.name>
-rw-r--r--gnu/packages/ruby.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 800ab194fe..4ba14f9adf 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -12666,3 +12666,24 @@ into Money objects.")
(description "This package provides a gem that calculates the exchange rate
using published rates from open-exchange-rates. Compatible with the money gem.")
(license license:expat)))
+
+(define-public ruby-roda
+ (package
+ (name "ruby-roda")
+ (version "3.57.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "roda" version))
+ (sha256
+ (base32 "0nkfxnbcfnriywvx9kpamp850cwjmqv8ssajc95d0aiyjr4kdrfy"))))
+ (build-system ruby-build-system)
+ (arguments
+ ;; No rakefile
+ `(#:tests? #f))
+ (propagated-inputs (list ruby-rack))
+ (home-page "http://roda.jeremyevans.net")
+ (synopsis "Routing Tree Web Toolkit")
+ (description "Roda is a routing tree web toolkit, designed for building fast
+and maintainable web applications in ruby.")
+ (license license:expat)))