summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSughosha <sughosha@proton.me>2022-06-22 08:08:04 +0200
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2022-06-26 16:56:19 +0200
commit33536ff4388b40ba3e2cdd38720ce7a2aa72d3e2 (patch)
tree01e68a118b5ff3e2ae9279d1d07c250b5563bdf8
parentfa60d0eaa410064b2481c0c4946329830dac7252 (diff)
downloadguix-patches-33536ff4388b40ba3e2cdd38720ce7a2aa72d3e2.tar
guix-patches-33536ff4388b40ba3e2cdd38720ce7a2aa72d3e2.tar.gz
gnu: Add gnome-shell-extension-sound-output-device-chooser.
* gnu/packages/gnome-xyz.scm (gnome-shell-extension-sound-output-device-chooser): New variable. Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
-rw-r--r--gnu/packages/gnome-xyz.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index 941f2b0cd6..35e5969775 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -1018,6 +1018,39 @@ GNOME Shell, including the top panel, dash and overview.")
directly inside GNOME Shell. It can manage stations and play streams.")
(license license:gpl3+)))
+(define-public gnome-shell-extension-sound-output-device-chooser
+ (package
+ (name "gnome-shell-extension-sound-output-device-chooser")
+ (version "43")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/kgshank/gse-sound-output-device-chooser")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1qk6ypyqbv8zwwlky6cgk9hgp1zh32jmzw4wza200g4v94ifkwm9"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list
+ #:tests? #f ; no check target
+ #:make-flags #~(list (string-append "INSTALL_DIR="
+ #$output
+ "/share/gnome-shell/extensions"))
+ #:phases
+ #~(modify-phases %standard-phases (delete 'configure))))
+ (native-inputs (list gettext-minimal `(,glib "bin")))
+ (inputs (list python))
+ (home-page
+ "https://extensions.gnome.org/extension/906/sound-output-device-chooser")
+ (synopsis "Sound output chooser for GNOME Shell")
+ (description "This extension shows a list of sound output and input devices
+in the status menu below the volume slider. Various active ports like HDMI,
+Speakers etc. of the same device are also displayed for selection.")
+ (license license:gpl3+)))
+
(define-public arc-theme
(package
(name "arc-theme")