summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-11-28 22:55:22 +0100
committerLudovic Courtès <ludo@gnu.org>2021-11-29 00:04:02 +0100
commit2ec5a1a576c45bd63e2ae11c081802deae66ed3b (patch)
tree50d7338224e56f3fa7243a542125af4a807b7068
parent0ca73525c89d79c481736350e5d3f4f0a18b4106 (diff)
downloadguix-patches-2ec5a1a576c45bd63e2ae11c081802deae66ed3b.tar
guix-patches-2ec5a1a576c45bd63e2ae11c081802deae66ed3b.tar.gz
gnu: python-dbus: Register 'python2-dbus' as the Python 2 variant.
This allows things like 'python2-notify2' to actually use the Python 2 variant of 'python-dbus'. * gnu/packages/python-xyz.scm (python-dbus)[properties]: New field. (python2-dbus)[inputs]: Remove unnecessary 'alist-delete' argument.
-rw-r--r--gnu/packages/python-xyz.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index cc35781dd6..7ff95373ce 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -8877,6 +8877,7 @@ parsing (browser/HTTP) user agent strings.")
(description "python-dbus provides bindings for libdbus, the reference
implementation of D-Bus.")
(home-page "https://www.freedesktop.org/wiki/Software/DBusBindings/")
+ (properties `((python2-variant . ,(delay python2-dbus))))
(license license:expat)))
(define-public python2-dbus
@@ -8884,8 +8885,7 @@ implementation of D-Bus.")
(name "python2-dbus")
(inputs `(("python" ,python-2)
,@(alist-delete "python"
- (package-inputs python-dbus)
- equal?)))
+ (package-inputs python-dbus))))
(arguments
`(#:configure-flags '("PYTHON_VERSION=2")))))