summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaghav Gururajan <raghavgururajan@disroot.org>2020-10-15 17:17:23 -0400
committerJulien Lepiller <julien@lepiller.eu>2020-10-20 00:23:20 +0200
commit2cbda6ded88cd281b66dbfe27e165d3cea7f1ed1 (patch)
tree871a076a5aa89742631c2f30356d399488d1d1d0
parenta9c72b9a5f18502d0fea492d20c8809586b782e3 (diff)
downloadguix-patches-2cbda6ded88cd281b66dbfe27e165d3cea7f1ed1.tar
guix-patches-2cbda6ded88cd281b66dbfe27e165d3cea7f1ed1.tar.gz
gnu: Add gajim-openpgp.
* gnu/packages/messaging.scm (gajim-openpgp): New variable. Signed-off-by: Julien Lepiller <julien@lepiller.eu>
-rw-r--r--gnu/packages/messaging.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 99e7092497..f683b89557 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -894,6 +894,40 @@ multi-client end-to-end encryption.")
"https://dev.gajim.org/gajim/gajim-plugins/-/wikis/OmemoGajimPlugin")
(license license:gpl3+)))
+(define-public gajim-openpgp
+ (package
+ (name "gajim-openpgp")
+ (version "1.3.5")
+ (source
+ (origin
+ (method url-fetch/zipbomb)
+ (uri
+ (string-append
+ "https://ftp.gajim.org/plugins_releases/openpgp_"
+ version ".zip"))
+ (sha256
+ (base32 "1jvpl2gjl5xxvsgxpmvh3mn2mm142dg2hknakkc32swb7l1fqx5m"))))
+ (build-system trivial-build-system)
+ (arguments
+ `(#:modules ((guix build utils))
+ #:builder
+ (begin
+ (use-modules (guix build utils))
+ (let* ((out (assoc-ref %outputs "out"))
+ (share (in-vicinity out "share/gajim/plugins"))
+ (source (assoc-ref %build-inputs "source")))
+ (mkdir-p share)
+ (copy-recursively source share)
+ #t))))
+ (propagated-inputs
+ `(("python-cryptography" ,python-cryptography)
+ ("python-gnupg" ,python-gnupg)))
+ (synopsis "Gajim OpenPGP plugin")
+ (description "Gajim-OpenPGP is a plugin that adds support for the OpenPGP
+Encryption to Gajim.")
+ (home-page "https://dev.gajim.org/gajim/gajim-plugins/-/wikis/OpenPGPplugin")
+ (license license:gpl3+)))
+
(define-public dino
(package
(name "dino")