summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAntero Mejr <antero@mailbox.org>2022-06-24 15:27:57 +0000
committerLudovic Courtès <ludo@gnu.org>2022-06-26 23:19:14 +0200
commit24dba9c5e78c3586a8b53296b59b41cf1f82817f (patch)
tree13076f8db873d6439ec9954fe1e3fae12ee765a8
parent53be886d18e0b7c205ede4890b0ea8189a39e602 (diff)
downloadguix-patches-24dba9c5e78c3586a8b53296b59b41cf1f82817f.tar
guix-patches-24dba9c5e78c3586a8b53296b59b41cf1f82817f.tar.gz
gnu: Add python-http-client.
* gnu/packages/python-web.scm (python-http-client): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/python-web.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 6c121907e6..088d7eb3d2 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -51,6 +51,7 @@
;;; Copyright © 2022 Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
;;; Copyright © 2022 Felix Gruber <felgru@posteo.net>
;;; Copyright © 2022 Peter Polidoro <peter@polidoro.io>
+;;; Copyright © 2022 Antero Mejr <antero@mailbox.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -7546,3 +7547,25 @@ resources using Web Application Description Language (WADL) files as guides.")
@end itemize")
(license license:expat)))
+(define-public python-http-client
+ (package
+ (name "python-http-client")
+ (version "3.3.7")
+ (home-page "https://github.com/sendgrid/python-http-client")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0z0ziw3f4zw5fj4spiwhhs2x8qs3i5999ry2p6a5sc8b1lkkj2zi"))
+ (snippet #~(begin
+ (use-modules (guix build utils))
+ (delete-file "tests/profile.py")))))
+ (build-system python-build-system)
+ (synopsis "HTTP REST client for Python")
+ (description
+ "This package provides access to any RESTful or RESTful-like API.")
+ (license license:expat)))