summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-06-23 21:08:14 +0300
committerEfraim Flashner <efraim@flashner.co.il>2022-06-26 14:42:58 +0300
commit181fdbe319b47de8ea042c90f019306a927c9d73 (patch)
tree11ff850a160d1ebe233a8fc821954503d33ef8bd
parent08a2a72a124f21fffaee45d0c71aa34cf49b8d70 (diff)
downloadguix-patches-181fdbe319b47de8ea042c90f019306a927c9d73.tar
guix-patches-181fdbe319b47de8ea042c90f019306a927c9d73.tar.gz
Revert "gnu: ldc-bootstrap-0.17: Add support for aarch64-linux."
This reverts commit 4f6ed3d2f8531ce1b75dc79365ce67587d8cb7e1. While this does allow building ldc on aarch64, it isn't actually helpful.
-rw-r--r--gnu/packages/dlang.scm8
1 files changed, 2 insertions, 6 deletions
diff --git a/gnu/packages/dlang.scm b/gnu/packages/dlang.scm
index 9acd01ed9d..d20b16cd3d 100644
--- a/gnu/packages/dlang.scm
+++ b/gnu/packages/dlang.scm
@@ -5,7 +5,7 @@
;;; Copyright © 2017 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2017, 2019, 2022 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2020 Guy Fleury Iteriteka <gfleury@disroot.org>
-;;; Copyright © 2021, 2022 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2021 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2022 ( <paren@disroot.org>
;;;
@@ -119,17 +119,13 @@ to a minimal test case.")
(sha256
(base32 "1q6hm4fkrcwys83x0p4kfg9xrc1b9g2qicqif2zy5z4nsfsb5vgs"))))
(build-system cmake-build-system)
- (supported-systems '("x86_64-linux" "i686-linux"
- "armhf-linux" "aarch64-linux"))
+ (supported-systems '("x86_64-linux" "i686-linux" "armhf-linux"))
(properties
;; Some of the tests take a very long time on ARMv7. See
;; <https://lists.gnu.org/archive/html/guix-devel/2018-02/msg00312.html>.
`((max-silent-time . ,(* 3600 3))))
(arguments
`(#:tests? #f ;requires obsolete python-lit test dependency
- ,@(if (target-aarch64?)
- '(#:system "armhf-linux")
- '())
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'unpack-submodule-sources