summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCyril Roelandt <tipecaml@gmail.com>2017-09-09 21:34:30 +0200
committerCyril Roelandt <tipecaml@gmail.com>2017-10-03 00:04:33 +0200
commit8e6ceb473753de3b17d51410d038bb6ad17decd1 (patch)
tree35d03cd4a3a2ab6a2946974fcd8ffe1facf6d859
parent9bb7c05e3db1adca51f9441c725e34599ba8e44c (diff)
downloadguix-patches-8e6ceb473753de3b17d51410d038bb6ad17decd1.tar
guix-patches-8e6ceb473753de3b17d51410d038bb6ad17decd1.tar.gz
gnu: Add python-nose-timer.
* gnu/packages/python.scm (python-nose-time, python2-nose-timer): New variables.
-rw-r--r--gnu/packages/python.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 94aca8fdce..2a83da6e9d 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -16323,3 +16323,31 @@ ignoring formatting changes.")
(define-public python2-pydiff
(package-with-python2 python-pydiff))
+
+(define-public python-nose-timer
+ (package
+ (name "python-nose-timer")
+ (version "0.7.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "nose-timer" version))
+ (patches
+ (search-patches
+ ;; This patch will not be needed in the next version.
+ ;; It is taken from the master branch.
+ "python-nose-timer-drop-ordereddict.patch"))
+ (sha256
+ (base32
+ "1s32ymsnby8lz2qk55ifj9zi50dqcg6swnj5cz2rmwxg2jsslsxp"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-nose" ,python-nose)
+ ("python-termcolor" ,python-termcolor)))
+ (home-page "https://github.com/mahmoudimus/nose-timer")
+ (synopsis "Timer plugin for nosetests")
+ (description "Shows how much time was needed to run individual tests.")
+ (license license:expat)))
+
+(define-public python2-nose-timer
+ (package-with-python2 python-nose-timer))