summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZ572 <873216071@qq.com>2022-06-24 21:34:18 +0800
committerLudovic Courtès <ludo@gnu.org>2022-06-26 01:00:18 +0200
commitf9488d5444679df3d47417a128ab4750ff26af13 (patch)
treed8610fd604d3433954c01c238afc8eb07d677cee
parent634506da75257522f6c9aecdf71ddd4fda4288f8 (diff)
downloadguix-patches-f9488d5444679df3d47417a128ab4750ff26af13.tar
guix-patches-f9488d5444679df3d47417a128ab4750ff26af13.tar.gz
gnu: guile-8sync: Update to 0.4.2-0.183b4f0.
* gnu/packages/guile-xyz.scm (guile-8sync): Update to 0.4.2-0.183b4f0. [source]: use git source. [native-inputs]: replace guile-2.2 with guile-3.0. [description]: remove some tips. <#:phases>: remove it. <#:make-flags>: set GUILE_AUTO_COMPILE in it. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/guile-xyz.scm53
1 files changed, 25 insertions, 28 deletions
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 2ed6617fd2..69cd569a2c 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -496,34 +496,31 @@ and then run @command{scm example.scm}.")
,@(package-arguments guile2.0-bash)))))
(define-public guile-8sync
- (package
- (name "guile-8sync")
- (version "0.4.2")
- (source (origin
- (method url-fetch)
- (uri (string-append "mirror://gnu/8sync/8sync-" version
- ".tar.gz"))
- (sha256
- (base32
- "031wm13srak3wsnll7j2mbbi29g1pcm4swdb71ds9yn567pn20qw"))))
- (build-system gnu-build-system)
- (native-inputs (list autoconf automake guile-2.2 pkg-config texinfo))
- (arguments
- `(#:phases (modify-phases %standard-phases
- (add-before 'configure 'setenv
- (lambda _
- ;; quiet warnings
- (setenv "GUILE_AUTO_COMPILE" "0")
- #t)))))
- (home-page "https://gnu.org/s/8sync/")
- (synopsis "Asynchronous actor model library for Guile")
- (description
- "GNU 8sync (pronounced \"eight-sync\") is an asynchronous programming
-library for GNU Guile based on the actor model.
-
-Note that 8sync is only available for Guile 2.2.")
- (properties '((upstream-name . "8sync")))
- (license license:lgpl3+)))
+ (let ((commit "183b4f02e68279d4984e79b79e06bfcf1861fcbf") (revision "0"))
+ (package
+ (name "guile-8sync")
+ (version (git-version "0.4.2" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (commit commit)
+ (url "https://git.savannah.gnu.org/git/8sync.git")))
+ (sha256
+ (base32
+ "0r22kxasv1zqnf1ykzyx6c226qxn1wgjb1gc54526bid24x508ij"))
+ (file-name (git-file-name name version))))
+ (build-system gnu-build-system)
+ (native-inputs (list autoconf automake guile-3.0 pkg-config texinfo))
+ (arguments
+ (list #:make-flags
+ #~(list "GUILE_AUTO_COMPILE=0")))
+ (home-page "https://gnu.org/s/8sync/")
+ (synopsis "Asynchronous actor model library for Guile")
+ (description
+ "GNU 8sync (pronounced \"eight-sync\") is an asynchronous programming
+library for GNU Guile based on the actor model.")
+ (properties '((upstream-name . "8sync")))
+ (license license:lgpl3+))))
(define-public guile-daemon
(package