summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
author( <paren@disroot.org>2022-06-15 19:53:50 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2022-06-19 02:00:00 +0200
commitdc8c869724afc0ead3a6020d75b4cee6018de21f (patch)
tree73140656279a78e29c3ca2459bbfac1ac5cbf29d
parenta47c9463d07263410ecddf6f9fe2b935a852a992 (diff)
downloadguix-patches-dc8c869724afc0ead3a6020d75b4cee6018de21f.tar
guix-patches-dc8c869724afc0ead3a6020d75b4cee6018de21f.tar.gz
gnu: rdmd: Rename to d-tools.
* gnu/packages/dlang.scm (rdmd): Rename this… (d-tools): …to this. [home-page, synopsis, description]: Update accordingly. Signed-off-by: Tobias Geerinckx-Rice <me@tobias.gr>
-rw-r--r--gnu/packages/dlang.scm17
1 files changed, 8 insertions, 9 deletions
diff --git a/gnu/packages/dlang.scm b/gnu/packages/dlang.scm
index 75e2155c83..799ec7f184 100644
--- a/gnu/packages/dlang.scm
+++ b/gnu/packages/dlang.scm
@@ -7,6 +7,7 @@
;;; Copyright © 2020 Guy Fleury Iteriteka <gfleury@disroot.org>
;;; Copyright © 2021, 2022 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2022 ( <paren@disroot.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -48,9 +49,9 @@
#:use-module (gnu packages xorg)
#:use-module (srfi srfi-1))
-(define-public rdmd
+(define-public d-tools
(package
- (name "rdmd")
+ (name "d-tools")
(version "2.077.1")
(source (origin
(method url-fetch)
@@ -76,14 +77,12 @@
(install-file "rdmd" bin)))))))
(native-inputs
(list ldc))
- (home-page "https://github.com/D-Programming-Language/tools/")
- (synopsis "Specialized equivalent to 'make' for the D language")
+ (home-page "https://github.com/dlang/tools")
+ (synopsis "Useful D-related tools")
(description
- "rdmd is a companion to the dmd compiler that simplifies the typical
-edit-compile-link-run or edit-make-run cycle to a rapid edit-run cycle. Like
-make and other tools, rdmd uses the relative dates of the files involved to
-minimize the amount of work necessary. Unlike make, rdmd tracks dependencies
-and freshness without requiring additional information from the user.")
+ "@code{d-tools} provides two useful tools for the D language: @code{rdmd},
+which runs D source files as scripts, and @code{dustmite}, which reduces D code
+to a minimal test case.")
(license license:boost1.0)))
;;; The 0.17.6 version is the last release to support being bootstrapped