summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaghav Gururajan <rg@raghavgururajan.name>2022-06-26 06:18:06 -0400
committerRaghav Gururajan <rg@raghavgururajan.name>2022-06-26 07:08:45 -0400
commitd89e75ee859de79165b2eadacdf63a48a7bcc0d0 (patch)
treec3b9d1145c0679a974c850e72a4770b01e491c9d
parent59363483f478f285707e1c53d35a9be9fffc4404 (diff)
downloadguix-patches-d89e75ee859de79165b2eadacdf63a48a7bcc0d0.tar
guix-patches-d89e75ee859de79165b2eadacdf63a48a7bcc0d0.tar.gz
gnu: gajim: Update to 1.4.5.
* gnu/packages/messaging.scm (gajim)[version]: Update to 1.4.5. [phases](disable-failing-tests): Remove phase. (wrap-env): Modify phase. [inputs]: Add gtksourceview and python-gssapi.
-rw-r--r--gnu/packages/messaging.scm15
1 files changed, 5 insertions, 10 deletions
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index dffc3861ab..f269d66d96 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -1175,7 +1175,7 @@ of xmpppy.")
(define-public gajim
(package
(name "gajim")
- (version "1.3.3")
+ (version "1.4.5")
(source
(origin
(method url-fetch)
@@ -1184,7 +1184,7 @@ of xmpppy.")
(version-major+minor version)
"/gajim-" version ".tar.gz"))
(sha256
- (base32 "1337qkpcv7j0fgws9scnk82mn2l7s17060vmrbh3ihinmxmbxg6x"))
+ (base32 "08a7kkc8vzjr5jxjkb96vs1bqnrgmmmcc5spy308z0zfxbpamsin"))
(patches (search-patches "gajim-honour-GAJIM_PLUGIN_PATH.patch"))))
(build-system python-build-system)
(arguments
@@ -1198,13 +1198,6 @@ of xmpppy.")
(guix build utils))
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'disable-failing-tests
- (lambda _
- ;; XXX Gajim builds fine on some (my) machines but fails elsewhere:
- ;; ModuleNotFoundError: No module named 'gajim.gui.emoji_data'
- ;; https://dev.gajim.org/gajim/gajim/-/issues/10478
- (delete-file "test/lib/gajim_mocks.py")
- (delete-file "test/unit/test_gui_interface.py")))
(replace 'check
(lambda _
;; Tests require a running X server.
@@ -1232,7 +1225,7 @@ of xmpppy.")
(wrap-program file
`("GST_PLUGIN_SYSTEM_PATH" ":" prefix (,gst-plugin-path))
`("GI_TYPELIB_PATH" ":" prefix (,gi-typelib-path)))))
- '("gajim" "gajim-remote" "gajim-history-manager"))))))))
+ '("gajim" "gajim-remote"))))))))
(native-search-paths
(list
(search-path-specification
@@ -1274,6 +1267,7 @@ of xmpppy.")
("gstreamer" ,gstreamer)
("gst-plugins-base" ,gst-plugins-base)
("gtk+" ,gtk+)
+ ("gtksourceview" ,gtksourceview)
("gupnp-igd" ,gupnp-igd)
("libnice" ,libnice)
("libsecret" ,libsecret)
@@ -1282,6 +1276,7 @@ of xmpppy.")
("network-manager" ,network-manager)
("python-css-parser" ,python-css-parser)
("python-dbus" ,python-dbus)
+ ("python-gssapi" ,python-gssapi)
("python-keyring" ,python-keyring)
("python-nbxmpp" ,python-nbxmpp)
("python-packaging" ,python-packaging)