summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArtyom V. Poptsov <poptsov.artyom@gmail.com>2022-06-25 13:20:02 +0300
committerJulien Lepiller <julien@lepiller.eu>2022-06-25 22:19:31 +0200
commitd039f9dc151eed8017a7f54682dbf713221b8005 (patch)
tree613644d060aa6fbda20d9cca965ba1a8a80b84ac
parent8a697e5c2599310f9586115c589a7db3e6df67d2 (diff)
downloadguix-patches-d039f9dc151eed8017a7f54682dbf713221b8005.tar
guix-patches-d039f9dc151eed8017a7f54682dbf713221b8005.tar.gz
gnu: Add maven-doxia-core.
* gnu/packages/maven.scm (maven-doxia-core): New variable. Signed-off-by: Julien Lepiller <julien@lepiller.eu>
-rw-r--r--gnu/packages/maven.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/maven.scm b/gnu/packages/maven.scm
index e5831ee614..f84f1ae177 100644
--- a/gnu/packages/maven.scm
+++ b/gnu/packages/maven.scm
@@ -3938,3 +3938,30 @@ method and a end of tag by @code{xxxx_()} method.")
(description "@samp{Doxia} is a content generation framework that provides
powerful techniques for generating static and dynamic content, supporting a
variety of markup languages.")))
+
+(define-public maven-doxia-core
+ (package
+ (inherit maven-doxia-sink-api)
+ (name "maven-doxia-core")
+ (arguments
+ `(#:jar-name "doxia-core.jar"
+ #:source-dir "doxia-core/src/main/java"
+ #:test-dir "doxia-core/src/test/java"
+ #:tests? #f ; tests require JUnit5
+ #:phases (modify-phases %standard-phases
+ (replace 'install
+ (install-from-pom "doxia-core/pom.xml")))))
+ (propagated-inputs (list maven-doxia-parent-pom
+ maven-doxia-sink-api
+ java-slf4j-api
+ java-javax-inject
+ java-plexus-utils
+ java-eclipse-sisu-plexus
+ java-commons-text))
+ (synopsis "Doxia core classes and interfaces")
+ (description
+ "Doxia is a content generation framework that provides powerful
+techniques for generating static and dynamic content, supporting a variety of
+markup languages.
+
+This package contains Doxia core classes and interfaces.")))