summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
author( <paren@disroot.org>2022-06-15 19:53:50 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2022-06-19 02:00:00 +0200
commitb438836833a15ef7894b59178886728303f58f43 (patch)
tree80aef02e6c8f6e6941172633df9a8df85859da74
parentf3c50743730a248ab36890b2eed1b772ad13340a (diff)
downloadguix-patches-b438836833a15ef7894b59178886728303f58f43.tar
guix-patches-b438836833a15ef7894b59178886728303f58f43.tar.gz
gnu: dub: Update to 1.23.0.
This also fixes Dub's build, which was previously failing because of how ancient it was. * gnu/packages/dlang.scm (dub): Update to 1.23.0. [arguments]: Set target CC & LD environment variables. Invoke build.d. Don't explicitly return #t from phases. [native-inputs]: Add d-tools and ld-gold-wrapper. Signed-off-by: Tobias Geerinckx-Rice <me@tobias.gr>
-rw-r--r--gnu/packages/dlang.scm17
1 files changed, 11 insertions, 6 deletions
diff --git a/gnu/packages/dlang.scm b/gnu/packages/dlang.scm
index cdbbe909cc..c17224d1eb 100644
--- a/gnu/packages/dlang.scm
+++ b/gnu/packages/dlang.scm
@@ -442,7 +442,7 @@ integration tests...\n")
(define-public dub
(package
(name "dub")
- (version "1.7.2")
+ (version "1.23.0")
(source
(origin
(method git-fetch)
@@ -451,7 +451,7 @@ integration tests...\n")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "073ibvgm1gphcqs1yjrav9ryp677nh3b194nxmvicwgvdc0sb6w9"))))
+ (base32 "06a4whsl1m600k096nwif83n7za3vr7pj1xwapncy5fcad1gmady"))))
(build-system gnu-build-system)
(arguments
`(#:tests? #f ; it would have tested itself by installing some packages (vibe etc)
@@ -460,17 +460,22 @@ integration tests...\n")
(delete 'configure) ; no configure script
(replace 'build
(lambda _
- (invoke "./build.sh")))
+ (setenv "CC" ,(cc-for-target))
+ (setenv "LD" ,(ld-for-target))
+ (invoke "./build.d")))
(replace 'install
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
(bin (string-append out "/bin")))
- (install-file "bin/dub" bin)
- #t))))))
+ (install-file "bin/dub" bin)))))))
(inputs
(list curl))
(native-inputs
- (list ldc))
+ (list d-tools
+ ldc
+ (module-ref (resolve-interface
+ '(gnu packages commencement))
+ 'ld-gold-wrapper)))
(home-page "https://code.dlang.org/getting_started")
(synopsis "Package and build manager for D projects")
(description