summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorzimoun <zimon.toutoune@gmail.com>2019-07-24 20:21:57 +0200
committerRicardo Wurmus <rekado@elephly.net>2019-07-24 23:05:39 +0200
commita6fedf1f37dd031829caae0b743016cd5d52f06c (patch)
tree1f2aa80388214f99fed0244f6854e0611eb26f6f
parentad8f46c69efd24915d380dba663c9f24746de1fc (diff)
downloadguix-patches-a6fedf1f37dd031829caae0b743016cd5d52f06c.tar
guix-patches-a6fedf1f37dd031829caae0b743016cd5d52f06c.tar.gz
gnu: Add r-flowcore.
* gnu/packages/bioconductor.scm (r-flowcore): New variable. Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
-rw-r--r--gnu/packages/bioconductor.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 649b64a4d7..93dec5bd1d 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -4797,3 +4797,33 @@ read mapping, read counting, SNP calling, structural variant detection and
gene fusion discovery. It can be applied to all major sequencing techologies
and to both short and long sequence reads.")
(license license:gpl3)))
+
+(define-public r-flowcore
+ (package
+ (name "r-flowcore")
+ (version "1.50.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "flowCore" version))
+ (sha256
+ (base32
+ "0pvcyzycsmgc8iw60q9xnhllfan6ihwpz3gvk8h1n9jmhpxzylan"))))
+ (properties `((upstream-name . "flowCore")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-bh" ,r-bh)
+ ("r-biobase" ,r-biobase)
+ ("r-biocgenerics" ,r-biocgenerics)
+ ("r-corpcor" ,r-corpcor)
+ ("r-graph" ,r-graph)
+ ("r-mass" ,r-mass)
+ ("r-matrixstats" ,r-matrixstats)
+ ("r-rcpp" ,r-rcpp)
+ ("r-rrcov" ,r-rrcov)))
+ (home-page "https://bioconductor.org/packages/flowCore")
+ (synopsis "Basic structures for flow cytometry data")
+ (description
+ "This package provides S4 data structures and basic functions to deal
+with flow cytometry data.")
+ (license license:artistic2.0)))