summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
author( <paren@disroot.org>2022-06-25 15:33:28 +0100
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2022-06-25 20:19:16 +0200
commit0de4318bb155db170a25f4b02e1350cb27715393 (patch)
tree002370977c8dac671d926c270fb4844853a31c03
parent4c63796545ce2a1f7cd556a831bb92c7b3166358 (diff)
downloadguix-patches-0de4318bb155db170a25f4b02e1350cb27715393.tar
guix-patches-0de4318bb155db170a25f4b02e1350cb27715393.tar.gz
gnu: packages: qbe: Update to 1.0.
* gnu/packages/c.scm (qbe): Update to 1.0. Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
-rw-r--r--gnu/packages/c.scm68
1 files changed, 31 insertions, 37 deletions
diff --git a/gnu/packages/c.scm b/gnu/packages/c.scm
index 3e49539473..1ce507119f 100644
--- a/gnu/packages/c.scm
+++ b/gnu/packages/c.scm
@@ -147,44 +147,38 @@ compiler while still keeping it small, simple, fast and understandable.")
(license (list license:bsd-2 license:bsd-3))))
(define-public qbe
- (let ((commit "2caa26e388b1c904d2f12fb09f84df7e761d8331")
- (revision "1"))
- (package
- (name "qbe")
- (version (git-version "0.0" revision commit))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "git://c9x.me/qbe")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1gv03ym0gqrl4wkbhysa82025xwrkr1fg44z814b6vnggwlqgljc"))))
- (build-system gnu-build-system)
- (arguments
- (list #:make-flags
- #~(list (string-append "CC=" #$(cc-for-target))
- (string-append "PREFIX=" #$output))
- #:phases
- #~(modify-phases %standard-phases
- (add-after 'unpack 'allow-cross-compilation
- (lambda _
- (substitute* "Makefile"
- (("`uname -m`") #$(or (%current-target-system)
- (%current-system))))))
- (add-after 'allow-cross-compilation 'use-$CC-for-tests
- (lambda _
- (substitute* "tools/test.sh"
- (("cc=\"cc -no-pie\"") "cc=\"${CC} -no-pie\""))))
- (delete 'configure))))
- (supported-systems (list "x86_64-linux" "aarch64-linux" "riscv64-linux"))
- (synopsis "Simple compiler backend")
- (description
- "QBE is a small compiler backend using an SSA-based intermediate
+ (package
+ (name "qbe")
+ (version "1.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "git://c9x.me/qbe")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0qx4a3fjjrp2m4dsn19rpbjf89k9w7w7l09s96jx8vv15vzsdgis"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list #:make-flags
+ #~(list (string-append "CC=" #$(cc-for-target))
+ (string-append "PREFIX=" #$output))
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'allow-cross-compilation
+ (lambda _
+ (substitute* "Makefile"
+ (("`uname -m`") #$(or (%current-target-system)
+ (%current-system))))))
+ (delete 'configure))))
+ (supported-systems (list "x86_64-linux" "aarch64-linux" "riscv64-linux"))
+ (synopsis "Simple compiler backend")
+ (description
+ "QBE is a small compiler backend using an SSA-based intermediate
language as input.")
- (home-page "https://c9x.me/compile/")
- (license license:expat))))
+ (home-page "https://c9x.me/compile/")
+ (license license:expat)))
(define-public python-pcpp
(package