summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-01 02:48:06 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-31 14:53:47 -0400
commitf3412d78c5931f233d3280d02de2ee72ac5557bf (patch)
tree11b2ae2e215e99add6bdf51af5a85320c31423d3
parent2d9550cf6a1e84a334aed1af04a1832d530b2f06 (diff)
downloadguix-patches-f3412d78c5931f233d3280d02de2ee72ac5557bf.tar
guix-patches-f3412d78c5931f233d3280d02de2ee72ac5557bf.tar.gz
gnu: Remove python2-beautifulsoup4.
* gnu/packages/python-xyz.scm (python2-beautifulsoup4): Delete variable.
-rw-r--r--gnu/packages/python-xyz.scm17
1 files changed, 1 insertions, 16 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 8197201aed..9fe692ef88 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -9400,22 +9400,7 @@ screen-scraping projects. It offers Pythonic idioms for navigating,
searching, and modifying a parse tree, providing a toolkit for
dissecting a document and extracting what you need. It automatically
converts incoming documents to Unicode and outgoing documents to UTF-8.")
- (license license:expat)
- (properties `((python2-variant . ,(delay python2-beautifulsoup4))))))
-
-(define-public python2-beautifulsoup4
- (let ((base (package-with-python2
- (strip-python2-variant python-beautifulsoup4))))
- (package/inherit base
- (version "4.9.3") ;last version to support Python 2
- (source
- (origin
- (method url-fetch)
- (uri (pypi-uri "beautifulsoup4" version))
- (sha256
- (base32
- "09gbd49mwz86k572r1231x2rdp82p42zlnw0bz9b9mfi58r9wwl4"))))
- (arguments `(#:python ,python-2)))))
+ (license license:expat)))
(define-public python-soupsieve
(package