summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2019-03-22 19:12:34 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2019-03-22 19:12:34 +0100
commitc6e775a875fc71172b793dd039ed32666315f764 (patch)
tree27975768db6e45167f3c426e7e0142653f8e3f53
parent813f866a90cf42bc8707712c07b30ed762ce5409 (diff)
downloadguix-patches-c6e775a875fc71172b793dd039ed32666315f764.tar
guix-patches-c6e775a875fc71172b793dd039ed32666315f764.tar.gz
gnu: tlp: Update to 1.2.1.
* gnu/packages/linux.scm (tlp): Update to 1.2.1.
-rw-r--r--gnu/packages/linux.scm10
1 files changed, 5 insertions, 5 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 0a7a5d8028..bc2219b1fa 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -11,7 +11,7 @@
;;; Copyright © 2016, 2017 Alex Kost <alezost@gmail.com>
;;; Copyright © 2016 Raymond Nicholson <rain1@openmailbox.org>
;;; Copyright © 2016 Mathieu Lirzin <mthl@gnu.org>
-;;; Copyright © 2016, 2018 Nicolas Goaziou <mail@nicolasgoaziou.fr>
+;;; Copyright © 2016, 2018, 2019 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2016, 2018, 2019 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2016 David Craven <david@craven.ch>
;;; Copyright © 2016 John Darrington <jmd@gnu.org>
@@ -4270,7 +4270,7 @@ Light is the successor of lightscript.")
(define-public tlp
(package
(name "tlp")
- (version "1.1")
+ (version "1.2.1")
(source (origin
(method url-fetch)
(uri (string-append
@@ -4280,7 +4280,7 @@ Light is the successor of lightscript.")
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "068hzmh90x600saynbl7iwg1pm0ywldn4jazyxx5y1fixs8s1qbn"))))
+ "0rcp9i0fisdm4h6799ffr696l1vl661fnwb2dij268nlwwmkr90g"))))
(inputs `(("bash" ,bash)
("dbus" ,dbus)
("ethtool" ,ethtool)
@@ -4310,7 +4310,8 @@ Light is the successor of lightscript.")
(setenv "TLP_NO_PMUTILS" "1")
(setenv "TLP_SBIN" (string-append out "/bin"))
(setenv "TLP_BIN" (string-append out "/bin"))
- (setenv "TLP_TLIB" (string-append out "/share/tlp-pm"))
+ (setenv "TLP_TLIB" (string-append out "/share/tlp"))
+ (setenv "TLP_FLIB" (string-append out "/share/tlp/func.d"))
(setenv "TLP_ULIB" (string-append out "/lib/udev"))
(setenv "TLP_CONF" "/etc/tlp")
(setenv "TLP_SHCPL"
@@ -4364,7 +4365,6 @@ Light is the successor of lightscript.")
a default configuration already optimized for battery life. Nevertheless,
TLP is customizable to fulfil system requirements. TLP settings are applied
every time the power supply source is changed.")
-
;; 'COPYING' is a custom version that says that one file is GPLv3+ and the
;; rest is GPLv2+.
(license (list license:gpl2+ license:gpl3+))))