summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-03-21 22:47:21 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-03-21 22:48:31 +0100
commit0c02f94f15fed0aa31e66caea0cb868820ce9ad1 (patch)
tree3ed8f403167fd4132034a498ff2394f271e27af8
parent0a3ba39633cb52abdb37cadb91ab55b9e88fcfee (diff)
downloadguix-patches-0c02f94f15fed0aa31e66caea0cb868820ce9ad1.tar
guix-patches-0c02f94f15fed0aa31e66caea0cb868820ce9ad1.tar.gz
gnu: Add r-picante.
* gnu/packages/cran.scm (r-picante): New variable.
-rw-r--r--gnu/packages/cran.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 1a5e4a3573..5bd164db30 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -11768,3 +11768,32 @@ R, enabling interactive analysis and visualization of genome-scale data.")
"This package provides wrappers on @code{regexpr} and @code{gregexpr} to
return the match results in tidy data frames.")
(license license:expat)))
+
+(define-public r-picante
+ (package
+ (name "r-picante")
+ (version "1.8")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "picante" version))
+ (sha256
+ (base32
+ "1bcq2j7fs89c2jib68qq6la67rxyg9raryf162mwvjakpf6k19l1"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-ape" ,r-ape)
+ ("r-nlme" ,r-nlme)
+ ("r-vegan" ,r-vegan)))
+ (home-page "https://cran.r-project.org/web/packages/picante/")
+ (synopsis "Integrating phylogenies and ecology")
+ (description
+ "This package provides functions for phylocom integration, community
+analyses, null-models, traits and evolution. It implements numerous
+ecophylogenetic approaches including measures of community phylogenetic and
+trait diversity, phylogenetic signal, estimation of trait values for
+unobserved taxa, null models for community and phylogeny randomizations, and
+utility functions for data input/output and phylogeny plotting. A full
+description of package functionality and methods are provided by Kembel et
+al. (2010).")
+ (license license:gpl2)))