summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-06-22 17:53:07 +0200
committerMarius Bakke <marius@gnu.org>2022-06-22 18:24:32 +0200
commitd9b497513f3c2beaa2ba828bc25374e1ffecbe43 (patch)
treec010836a7f11a64ad8dd9ce57bd07e20eac8a6ba
parent92121b8e9db9541b0fdf0e6e0b17e28e03a01277 (diff)
downloadguix-patches-d9b497513f3c2beaa2ba828bc25374e1ffecbe43.tar
guix-patches-d9b497513f3c2beaa2ba828bc25374e1ffecbe43.tar.gz
gnu: python-sanic-testing: Fix build.
* gnu/packages/python-web.scm (python-sanic-testing)[arguments]: Add #:phases.
-rw-r--r--gnu/packages/python-web.scm11
1 files changed, 10 insertions, 1 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index cbc2d843ea..e4f2c2fa2d 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -6332,7 +6332,16 @@ the @code{BasicRouter}.")
(arguments
;; PyPi sources does not contain tests, recursive dependency on
;; python-sanic.
- (list #:tests? #f))
+ (list #:tests? #f
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'loosen-requirements
+ (lambda _
+ ;; Don't place an upper boundary on httpx version.
+ ;; https://github.com/sanic-org/sanic-testing/pull/39
+ (substitute* "setup.py"
+ (("httpx>=0\\.18,<0\\.23")
+ "httpx>=0.18")))))))
(propagated-inputs (list python-httpx python-sanic-bootstrap
python-websockets))
(home-page "https://github.com/sanic-org/sanic-testing/")