summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGabriel Wicki <gabriel@erlikon.ch>2022-06-21 02:38:40 +0200
committerLudovic Courtès <ludo@gnu.org>2022-06-22 23:15:33 +0200
commitaa2fd99fb1d5fd44811d0dd4e176feaf7a945528 (patch)
tree5250766fb20a0b9266783f62eea08797fdf9448c
parent344ac798739a8a608ad55a62d344092c3b5e46ca (diff)
downloadguix-patches-aa2fd99fb1d5fd44811d0dd4e176feaf7a945528.tar
guix-patches-aa2fd99fb1d5fd44811d0dd4e176feaf7a945528.tar.gz
gnu: sent: Apply guix style
* gnu/packages/suckless.scm (sent): Apply `guix style`. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/suckless.scm34
1 files changed, 17 insertions, 17 deletions
diff --git a/gnu/packages/suckless.scm b/gnu/packages/suckless.scm
index f5eb8b43f5..d8c764e901 100644
--- a/gnu/packages/suckless.scm
+++ b/gnu/packages/suckless.scm
@@ -520,31 +520,31 @@ point surf to another URI by setting its XProperties.")
(build-system gnu-build-system)
(arguments
`(#:phases (modify-phases %standard-phases
- (delete 'configure) ; no configuration
+ (delete 'configure) ;no configuration
(add-before 'build 'patch-farbfeld
(lambda* (#:key inputs #:allow-other-keys)
(substitute* "config.def.h"
(("2ff") (search-input-file inputs "/bin/2ff"))))))
- #:tests? #f ; no test suite
+ #:tests? #f ;no test suite
#:make-flags
(let ((pkg-config (lambda (flag)
- (string-append
- "$(shell pkg-config " flag " "
- "xft fontconfig x11 libpng)"))))
- (list (string-append "CC=" ,(cc-for-target))
+ (string-append "$(shell pkg-config " flag " "
+ "xft fontconfig x11 libpng)"))))
+ (list (string-append "CC="
+ ,(cc-for-target))
(string-append "PREFIX=" %output)
- (string-append "INCS=-I. " (pkg-config "--cflags"))
- (string-append "LIBS=" (pkg-config "--libs") " -lm")))))
- (native-inputs
- (list pkg-config))
- (inputs
- `(("farbfeld" ,farbfeld)
- ("libpng" ,libpng)
- ("libx11" ,libx11)
- ("libxft" ,libxft)
- ("fontconfig" ,fontconfig)))
+ (string-append "INCS=-I. "
+ (pkg-config "--cflags"))
+ (string-append "LIBS="
+ (pkg-config "--libs") " -lm")))))
+ (native-inputs (list pkg-config))
+ (inputs `(("farbfeld" ,farbfeld) ("libpng" ,libpng)
+ ("libx11" ,libx11)
+ ("libxft" ,libxft)
+ ("fontconfig" ,fontconfig)))
(synopsis "Plain-text presentation tool")
- (description "Sent uses plain-text files and PNG images to create slideshow
+ (description
+ "Sent uses plain-text files and PNG images to create slideshow
presentations. Each paragraph represents a slide in the presentation.
Especially for presentations using the Takahashi method this is very nice and
allows you to write down the presentation for a quick lightning talk within a