summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-06-04 23:32:46 +0200
committerLudovic Courtès <ludo@gnu.org>2014-06-04 23:32:46 +0200
commit9d9b576bcd51049f674933ce5406f9ce549b9bf6 (patch)
treebfac82bd0c9c821553d56e7996a21035036f747f
parentea31dbbc18e616196ed7bda61e29178658540e7e (diff)
downloadguix-patches-9d9b576bcd51049f674933ce5406f9ce549b9bf6.tar
guix-patches-9d9b576bcd51049f674933ce5406f9ce549b9bf6.tar.gz
gnu: Set proper source location for 'gcc-final'.
* gnu/packages/base.scm (gcc-final)[location]: New field. Reported by Andreas Enge <andreas@enge.fr>.
-rw-r--r--gnu/packages/base.scm1
1 files changed, 1 insertions, 0 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index 09cbe8915b..2e16f325ef 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -971,6 +971,7 @@ exec ~a/bin/~a-~a -B~a/lib -Wl,-dynamic-linker -Wl,~a/~a \"$@\"~%"
;; The final GCC.
(package (inherit gcc-boot0)
(name "gcc")
+ (location (source-properties->location (current-source-location)))
(arguments
`(#:guile ,%bootstrap-guile
#:implicit-inputs? #f