summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-06-22 17:27:06 +0200
committerMarius Bakke <marius@gnu.org>2022-06-22 18:24:32 +0200
commit8ef4d33a177635b58f2e5e51d68d1bc52f685ff1 (patch)
treef3dc4eeeb8b40788447a454a92bc32c984f94773
parenteb3aee6cd0f70a4f36630fd9d4ad38d4e00b4283 (diff)
downloadguix-patches-8ef4d33a177635b58f2e5e51d68d1bc52f685ff1.tar
guix-patches-8ef4d33a177635b58f2e5e51d68d1bc52f685ff1.tar.gz
gnu: python-pydantic: Update to 1.9.1.
* gnu/packages/python-xyz.scm (python-pydantic): Update to 1.9.1. [arguments]: Remove phase 'disable-test.
-rw-r--r--gnu/packages/python-xyz.scm25
1 files changed, 2 insertions, 23 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 948c007ae2..c0bb67d76a 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -5038,7 +5038,7 @@ which can produce feeds in RSS 2.0, RSS 0.91, and Atom formats.")
(define-public python-pydantic
(package
(name "python-pydantic")
- (version "1.9.0")
+ (version "1.9.1")
(source
(origin
(method git-fetch)
@@ -5047,32 +5047,11 @@ which can produce feeds in RSS 2.0, RSS 0.91, and Atom formats.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "14wj3k9007fpbxk7593w6gdqrr68yzrsw4a41sj5ji4cv3r8z18b"))))
+ (base32 "1406kgppqa7524mxllsipj7gb8fn7pwf51l11lqik59xjhsfv94f"))))
(build-system python-build-system)
(arguments
'(#:phases
(modify-phases %standard-phases
- (add-before 'check 'disable-test
- (lambda _
- ;; Reported upstream:
- ;; <https://github.com/samuelcolvin/pydantic/issues/1580>.
- ;; Disable the faulty test as the fix is unclear.
- (substitute* "tests/test_validators.py"
- (("test_assert_raises_validation_error")
- "_test_assert_raises_validation_error"))
-
- ;; These fail because of <https://bugs.python.org/issue40398>.
- ;; Remove after Python has been upgraded to >= 3.9.
- (substitute* "tests/test_generics.py"
- (("assert replace_types\\(Callable, \\{T: int\\}\\) == Callable")
- ""))
- (substitute* "tests/test_schema.py"
- (("test_unenforced_constraints_schema")
- "_test_unenforced_constraints_schema"))
-
- ;; Disable tests for the Hypothesis plugin because it is tricky
- ;; to configure in the build container.
- (delete-file "tests/test_hypothesis_plugin.py")))
(replace 'check
(lambda _ (invoke "pytest" "-vv"))))))
(native-inputs