summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-06-21 16:29:48 +0200
committerMarius Bakke <marius@gnu.org>2022-06-21 17:30:44 +0200
commit8dbc8d480204df73dafb890c5695108a0a0cb811 (patch)
tree01616c144d709d1784745b477b9f043888340e2a
parent705c609048a221a76394c5a0b477b348e08db6ef (diff)
downloadguix-patches-8dbc8d480204df73dafb890c5695108a0a0cb811.tar
guix-patches-8dbc8d480204df73dafb890c5695108a0a0cb811.tar.gz
gnu: python-cliff: Update to 3.10.1.
* gnu/packages/openstack.scm (python-cliff): Update to 3.10.1. [propagated-inputs]: Add PYTHON-AUTOPAGE. Remove PYTHON-BANDIT.
-rw-r--r--gnu/packages/openstack.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/openstack.scm b/gnu/packages/openstack.scm
index 4c28bb9283..e121c7ffdb 100644
--- a/gnu/packages/openstack.scm
+++ b/gnu/packages/openstack.scm
@@ -77,25 +77,25 @@ scanning all the files it generates a report.")
(define-public python-cliff
(package
(name "python-cliff")
- (version "3.5.0")
+ (version "3.10.1")
(source
(origin
(method url-fetch)
(uri (pypi-uri "cliff" version))
(sha256
(base32
- "0n8pzr0mnn9lq2mykds69ij2xrn0fsirh4ndmkx0mzydbx5niysv"))))
+ "180059m5ky3hlw2m9fszh4h2ykja8zl7ql5dsxjijiv47hzywnh4"))))
(build-system python-build-system)
(arguments
`(#:tests? #f))
(native-inputs
(list python-pbr))
(propagated-inputs
- (list python-cmd2
+ (list python-autopage
+ python-cmd2
python-prettytable
python-pyparsing
python-pyyaml
- python-bandit
python-stevedore))
(home-page "https://opendev.org/openstack/cliff")
(synopsis "Framework for building command line programs")