summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Kehayias <john.kehayias@protonmail.com>2022-06-21 21:22:26 -0400
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2022-06-22 21:09:23 +0200
commit4f9ac2afc76048a8e042a8c874d3a170e7655742 (patch)
tree732b06f33436643e763094697975e577ca9d789d
parent1766a502dae8fa344baac5467783619728c58249 (diff)
downloadguix-patches-4f9ac2afc76048a8e042a8c874d3a170e7655742.tar
guix-patches-4f9ac2afc76048a8e042a8c874d3a170e7655742.tar.gz
gnu: emacs: Fix tramp-remote-path.
This variable was moved from tramp-sh.el to tramp.el, causing the substitute* snippet which patches it to silently fail. See also <https://issues.guix.gnu.org/55443>. * gnu/packages/emacs.scm (emacs)[source]<snippet>: Patch tramp.el rather than tramp-sh.el. Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
-rw-r--r--gnu/packages/emacs.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 31b5c04324..0de4b7a5d5 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -106,7 +106,7 @@
;; Make sure Tramp looks for binaries in the right places on
;; remote Guix System machines, where 'getconf PATH' returns
;; something bogus.
- (substitute* "net/tramp-sh.el"
+ (substitute* "net/tramp.el"
;; Patch the line after "(defcustom tramp-remote-path".
(("\\(tramp-default-remote-path")
(format #f "(tramp-default-remote-path ~s ~s ~s ~s "