summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2021-10-21 03:52:49 +0000
committerEfraim Flashner <efraim@flashner.co.il>2021-11-08 22:36:34 +0200
commit71dc19d9cba0c8d03540ab62cf5390442c0f8948 (patch)
treee82391492ecace5e8878cdaaf54c2ab33c9d4543
parent2181133eed4d392db5ad533f5e22b0dbb1951f35 (diff)
downloadguix-patches-71dc19d9cba0c8d03540ab62cf5390442c0f8948.tar
guix-patches-71dc19d9cba0c8d03540ab62cf5390442c0f8948.tar.gz
gnu: Add python-cachelib.
* gnu/packages/python-xyz.scm (python-cachelib): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
-rw-r--r--gnu/packages/python-xyz.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 2836cf799c..6cf42f1109 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -11154,6 +11154,25 @@ package to infer file type and MIME type checking the magic numbers
signature of a file or buffer.")
(license license:expat)))
+(define-public python-cachelib
+ (package
+ (name "python-cachelib")
+ (version "0.1.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "cachelib" version))
+ (sha256
+ (base32 "0vs7nimlbhqy9kjcc90nswkhs3kgl28ag19jssx9qwlcsrkmmsa7"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:tests? #f)) ;no tests
+ (home-page "https://github.com/pallets/cachelib")
+ (synopsis "Collection of cache libraries")
+ (description "Cachelib is a library extracted from @code{werkzeug} which
+provides a collection of cache libraries in the same API interface.")
+ (license license:bsd-3)))
+
(define-public python-legacy-api-wrap
(package
(name "python-legacy-api-wrap")